Cellular Connectivity Issues with T-Mobile Germany

Incident Report for TinyMobileRobots

Update

Our IoT connectivity provider is actively investigating the issue and we are awaiting their findings. We do not yet have a root cause or an estimated time to resolution.

In the meantime, the workaround remains the same: manually switch to a different mobile operator on the affected tablet or robot. Devices will then register normally and regain data connectivity.
Posted Sep 09, 2026 - 15:38 CEST

Investigating

We have been notified of and are currently investigating reports of SIM cards failing to connect to the T-Mobile Germany network. Affected devices may be unable to register on the network or experience poor network connectivity, resulting in loss of cellular data connectivity. Devices on other networks and roaming profiles are not affected.
Posted Sep 08, 2026 - 15:33 CEST
This incident affects: SIM & Mobile Network (Europe).